# New ports collection makefile for: udunits
# Date created: 31 December 2004
# Whom: Greg Lewis <glewis@FreeBSD.org>
#
# $FreeBSD: ports/science/udunits/Makefile,v 1.7 2007/04/04 03:31:05 glewis Exp $
#
PORTNAME= udunits
PORTVERSION= 1.12.4
CATEGORIES= science math
MASTER_SITES= ftp://ftp.unidata.ucar.edu/pub/${PORTNAME}/ \
${MASTER_SITE_LOCAL:S|%SUBDIR%|glewis/udunits|}
EXTRACT_SUFX= .tar.Z
MAINTAINER= ports@FreeBSD.org
COMMENT= A library for manipulating units of physical quantities
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}/src
GNU_CONFIGURE= yes
USE_PERL5= yes
CFLAGS+= -fPIC
MAN1= udunits.1 \
udunitsperl.1
MAN3= udunits.3 \
udunits.3f
post-build:
${REINPLACE_CMD} -e 's: doc_[^_]*_install::' \
-e 's: doc_install::' \
"${WRKSRC}/perl/Makefile"
.include <bsd.port.mk>
syntax highlighted by Code2HTML, v. 0.9.1