head 1.15;
access;
symbols
RELENG_4_0_0_RELEASE:1.9
RELENG_4:1.9.0.2
RELENG_4_BP:1.9
RELENG_3_4_0_RELEASE:1.6.2.1
RELENG_3_3_0_RELEASE:1.6.2.1
RELENG_3_2_PAO:1.6.0.4
RELENG_3_2_PAO_BP:1.6
RELENG_3_2_0_RELEASE:1.6
RELENG_3_1_0_RELEASE:1.6
RELENG_3:1.6.0.2
RELENG_3_BP:1.6
RELENG_2_2_8_RELEASE:1.4
RELENG_3_0_0_RELEASE:1.6
RELENG_2_2_7_RELEASE:1.4
RELENG_2_2_6_RELEASE:1.4
RELENG_2_2_5_RELEASE:1.4
bsd_44_lite_2:1.1.1.1
RELENG_2_2_2_RELEASE:1.4
RELENG_2_2_1_RELEASE:1.4
RELENG_2_2_0_RELEASE:1.4
RELENG_2_1_7_RELEASE:1.3
RELENG_2_1_6_1_RELEASE:1.3
RELENG_2_1_6_RELEASE:1.3
RELENG_2_2:1.4.0.2
RELENG_2_2_BP:1.4
RELENG_2_1_5_RELEASE:1.3
RELENG_2_1_0_RELEASE:1.3
RELENG_2_1_0:1.3.0.4
RELENG_2_1_0_BP:1.3
RELENG_2_0_5_RELEASE:1.3
RELENG_2_0_5:1.3.0.2
RELENG_2_0_5_BP:1.3
RELENG_2_0_5_ALPHA:1.3
RELEASE_2_0:1.2
BETA_2_0:1.2
ALPHA_2_0:1.2.0.2
bsd_44_lite:1.1.1.1
CSRG:1.1.1;
locks;
comment @# @;
1.15
date 2000.05.23.04.17.57; author tim; state Exp;
branches;
next 1.14;
1.14
date 2000.05.22.23.34.37; author tim; state Exp;
branches;
next 1.13;
1.13
date 2000.05.22.17.28.42; author tim; state Exp;
branches;
next 1.12;
1.12
date 2000.05.22.17.19.38; author tim; state Exp;
branches;
next 1.11;
1.11
date 2000.05.12.18.10.17; author hoek; state Exp;
branches;
next 1.10;
1.10
date 2000.05.12.03.52.03; author hoek; state Exp;
branches;
next 1.9;
1.9
date 99.09.10.07.39.25; author ru; state Exp;
branches;
next 1.8;
1.8
date 99.09.03.22.31.13; author hoek; state Exp;
branches;
next 1.7;
1.7
date 99.08.28.01.04.14; author peter; state Exp;
branches;
next 1.6;
1.6
date 97.02.22.19.56.17; author peter; state Exp;
branches
1.6.2.1;
next 1.5;
1.5
date 97.01.14.07.03.18; author jkh; state Exp;
branches;
next 1.4;
1.4
date 95.07.25.00.36.40; author bde; state Exp;
branches
1.4.2.1;
next 1.3;
1.3
date 95.02.21.03.46.45; author wollman; state Exp;
branches
1.3.4.1;
next 1.2;
1.2
date 94.09.11.22.00.16; author rgrimes; state Exp;
branches;
next 1.1;
1.1
date 94.05.27.12.30.44; author rgrimes; state Exp;
branches
1.1.1.1;
next ;
1.1.1.1
date 94.05.27.12.30.45; author rgrimes; state Exp;
branches;
next ;
1.3.4.1
date 99.09.05.11.35.12; author peter; state Exp;
branches;
next ;
1.4.2.1
date 99.09.05.11.32.54; author peter; state Exp;
branches;
next ;
1.6.2.1
date 99.08.29.15.31.12; author peter; state Exp;
branches;
next ;
desc
@@
1.15
log
@Add search.c.
@
text
@# From: @@(#)Makefile 8.1 (Berkeley) 6/6/93
# $FreeBSD: src/usr.bin/more/Makefile,v 1.10 2000/05/12 03:52:03 hoek Exp $
#
PROG= more
CFLAGS+=-I${.CURDIR} -I${.OBJDIR} -DTERMIOS
SRCS= ch.c command.c help.c input.c line.c linenum.c macro.c main.c marks.c \
ncommand.c option.c os.c output.c position.c prim.c screen.c search.c \
signal.c tags.c ttyin.c
DPADD= ${LIBTERMCAP}
LDADD= -ltermcap
CLEANFILES+= defrc.h
EXAMPDIR= /usr/share/examples/more
EXAMPLES= default.morerc less.morerc most.morerc
defrc.h: default.morerc
@@echo '/* ${.TARGET:T} auto-generated from ${.ALLSRC:T} */' \
> ${.TARGET}
@@echo '#define DEFRC "\' >> ${.TARGET}
sed -e 's/\\/\\\\/g' -e 's/\"/\\\"/g' -e 's/$$/\\n\\/' \
< ${.ALLSRC} >> ${.TARGET}
@@echo \" >> ${.TARGET}
beforeinstall:
${INSTALL} ${COPY} -o ${SHAREOWN} -g ${SHAREGRP} -m ${SHAREMODE} \
${.CURDIR}/more.help ${DESTDIR}/usr/share/misc
.for xzamp in ${EXAMPLES}
${INSTALL} ${COPY} -o ${SHAREOWN} -g ${SHAREGRP} -m ${SHAREMODE} \
${.CURDIR}/${xzamp} ${DESTDIR}${EXAMPDIR}/${xzamp}
.endfor
.include <bsd.prog.mk>
@
1.14
log
@Change filename of mark.c to marks.c
@
text
@d8 2
a9 2
ncommand.c option.c os.c output.c position.c prim.c screen.c signal.c \
tags.c ttyin.c
@
1.13
log
@mv marks.c mark.c
@
text
@d7 1
a7 1
SRCS= ch.c command.c help.c input.c line.c linenum.c macro.c main.c mark.c \
@
1.12
log
@Fix dependency of main.c on defrc.h.
@
text
@d7 1
a7 1
SRCS= ch.c command.c help.c input.c line.c linenum.c macro.c main.c \
@
1.11
log
@Backout previous commit to this file: it dies in buildworld environment.
I probably forgot to put an ${.OBJDIR} somewhere. I'll redo the change
later when I get a chance to test that thesis.
@
text
@d7 1
a7 1
SRCS= ch.c command.c defrc.h help.c input.c line.c linenum.c macro.c main.c \
@
1.10
log
@Only main.c depends on defrc.h
@
text
@d2 1
a2 1
# $FreeBSD: src/usr.bin/more/Makefile,v 1.9 1999/09/10 07:39:25 ru Exp $
d7 1
a7 1
SRCS= ch.c command.c help.c input.c line.c linenum.c macro.c main.c \
a16 2
main.c: defrc.h
@
1.9
log
@Unbroke `make -s' case.
PR: 13676
Submitted by: wollman
@
text
@d2 1
a2 1
# $FreeBSD: src/usr.bin/more/Makefile,v 1.8 1999/09/03 22:31:13 hoek Exp $
d7 1
a7 1
SRCS= ch.c command.c defrc.h help.c input.c line.c linenum.c macro.c main.c \
d17 2
@
1.8
log
@Thorough revamp of how input commands are processed. This allows customization
of user keys (documentation pending). The only key whose semantics have
changed is the capital 'N' key, which now performs a repeat-search in the
opposite direction (just like in vi).
This commit is a little bulkier than what I had originally planned. I'm not
completely happy with the direction it went, but it's definately an
improvement, and the alternative is to continue becoming irrelevant compared
to GNU less. (Does anyone even _use_ /usr/bin/more these days?)
@
text
@d2 1
a2 1
# $FreeBSD: src/usr.bin/more/Makefile,v 1.7 1999/08/28 01:04:14 peter Exp $
d19 1
a19 1
@@${ECHO} '/* ${.TARGET:T} auto-generated from ${.ALLSRC:T} */' \
d21 1
a21 1
@@${ECHO} '#define DEFRC "\' >> ${.TARGET}
d24 1
a24 1
@@${ECHO} \" >> ${.TARGET}
@
1.7
log
@$Id$ -> $FreeBSD$
@
text
@d2 2
a3 1
# $FreeBSD$
d6 4
a9 4
CFLAGS+=-I${.CURDIR} -DTERMIOS
SRCS= ch.c command.c decode.c help.c input.c line.c linenum.c main.c \
option.c os.c output.c position.c prim.c screen.c signal.c tags.c \
ttyin.c
d13 13
d27 6
a32 2
${INSTALL} -c -o ${BINOWN} -g ${BINGRP} -m 444 ${.CURDIR}/more.help \
${DESTDIR}/usr/share/misc
@
1.6
log
@Revert $FreeBSD$ to $Id$
@
text
@d2 1
a2 1
# $Id$
@
1.6.2.1
log
@$Id$ -> $FreeBSD$
@
text
@d2 1
a2 1
# $FreeBSD$
@
1.5
log
@Make the long-awaited change from $Id$ to $FreeBSD$
This will make a number of things easier in the future, as well as (finally!)
avoiding the Id-smashing problem which has plagued developers for so long.
Boy, I'm glad we're not using sup anymore. This update would have been
insane otherwise.
@
text
@d2 1
a2 1
# $FreeBSD$
@
1.4
log
@Change `install' to `${INSTALL}' so that default install flags can be
specified in the top level Makefiles.
@
text
@d2 1
a2 1
# $Id: Makefile,v 1.3 1995/02/21 03:46:45 wollman Exp $
@
1.4.2.1
log
@$Id$ -> $FreeBSD$
@
text
@d2 1
a2 1
# $FreeBSD$
@
1.3
log
@more now uses POSIX regular expressions and no longer needs libcompat.
@
text
@d2 1
a2 1
# $Id$
d13 1
a13 1
install -c -o ${BINOWN} -g ${BINGRP} -m 444 ${.CURDIR}/more.help \
@
1.3.4.1
log
@$Id$ -> $FreeBSD$
@
text
@d2 1
a2 1
# $FreeBSD$
@
1.2
log
@Change all references to LIBTERM and -ltermlib to LIBTERMCAP and -ltermcap
@
text
@d1 2
a2 1
# @@(#)Makefile 8.1 (Berkeley) 6/6/93
d5 1
a5 1
CFLAGS+=-I${.CURDIR}
d9 2
a10 2
DPADD= ${LIBTERMCAP} ${LIBCOMPAT}
LDADD= -ltermcap -lcompat
@
1.1
log
@Initial revision
@
text
@d8 1
a8 1
DPADD= ${LIBTERM} ${LIBCOMPAT}
@
1.1.1.1
log
@BSD 4.4 Lite Usr.bin Sources
@
text
@@
syntax highlighted by Code2HTML, v. 0.9.1