# New ports collection makefile for:	915resolution
# Date created:				30 Apr 2004
# Whom:					Remington Lang <MrL0Lz@gmail.com>
#
# $FreeBSD: ports/sysutils/915resolution/Makefile,v 1.6 2007/07/09 15:56:36 tdb Exp $

PORTNAME=	915resolution
PORTVERSION=	0.5.3
PORTEPOCH=	1
CATEGORIES=	sysutils
MASTER_SITES=	http://www.geocities.com/stomljen/ \
		${MASTER_SITE_LOCAL}
MASTER_SITE_SUBDIR=	ehaupt

MAINTAINER=	MrL0Lz@gmail.com
COMMENT=	Resolution tool for Intel i915 video cards

USE_RC_SUBR=	915resolution.sh

PLIST_FILES=	sbin/915resolution
PORTDOCS=	README.txt chipset_info.txt

ONLY_FOR_ARCHS=	i386

.include <bsd.port.pre.mk>

.if ${OSVERSION} < 600034
BROKEN=		Does not build
.endif

do-build:
	cd ${WRKSRC} && \
		${CC} ${CFLAGS} 915resolution.c -o 915resolution

do-install:
	${INSTALL_PROGRAM} ${WRKSRC}/915resolution ${PREFIX}/sbin
.if !defined(NOPORTDOCS)
	${INSTALL} -o ${DOCOWN} -g ${DOCGRP} -m ${BINMODE} -d ${DOCSDIR}
.for f in ${PORTDOCS}
	${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
.endfor
.endif

.include <bsd.port.post.mk>


syntax highlighted by Code2HTML, v. 0.9.1