#
# Version $Id: Makefile.in 4463 2007-03-30 21:46:04Z kerns $
#
#
# This file is pulled in by all the Unix Bacula Makefiles
# so it has all the "common" definitions
#
DATE="10 November 2007"
LSMDATE=10Nov07
VERSION=2.2.6
VERNAME=bacula-$(VERSION)#
MAINT=Kern Sibbald#
MAINTEMAIL=<kern@sibbald.com>#
WEBMAINT=#
WEBMAINTEMAIL=#
WEBPAGE=#
FTPSITENAME=#
FTPSITEDIR=#
#-------------------------------------------------------------------------
SHELL = /bin/sh
# Installation target directories & other installation stuff
prefix =
exec_prefix =
binprefix =
manprefix =
sbindir = /sbin
sysconfdir = /etc
scriptdir = /etc
mandir = /usr/share/man
manext = 8
NO_ECHO = @
# Tools & program stuff
CC = cc
CPP = cc -E
CXX = /usr/bin/c++
MV = /usr/local/bin/mv
RM = /usr/local/bin/rm
RMF = /usr/local/bin/rm -f
CP = /usr/local/bin/cp
SED = /usr/local/bin/sed
AWK = /usr/local/bin/gawk
ECHO = /usr/local/bin/echo
CMP = /usr/bin/cmp
TBL = /usr/bin/tbl
AR = /usr/bin/ar
RANLIB = ranlib
MKDIR = /mnt/gmirror/ports/sysutils/bacula-client/work/bacula-2.2.6/autoconf/mkinstalldirs
INSTALL = /usr/bin/install -c -o root -g wheel
# add the -s to the following in PRODUCTION mode
INSTALL_PROGRAM = /usr/bin/install -c -o root -g wheel -m 0754
INSTALL_DATA = /usr/bin/install -c -o root -g wheel -m 644
INSTALL_SCRIPT = /usr/bin/install -c -o root -g wheel -m 0754
INSTALL_CONFIG = /usr/bin/install -c -o root -g wheel -m 640
# Flags & libs
CFLAGS = -fno-common
CPPFLAGS = -I/usr/include/readline -I/usr/local/include
LDFLAGS = -L/usr/local/lib
TTOOL_LDFLAGS =
#DEFS = -DHAVE_CONFIG_H
LIBS = -lpthread -lintl
WRAPLIBS =
DINCLUDE =
DLIB =
DB_LIBS =
PYTHON_LIBS =
PYTHON_INC =
OPENSSL_LIBS =
# Windows (cygwin) flags
WCFLAGS =
WLDFLAGS =
# X Include directory
#XINC = -I/usr/X11R6/include @XPM_CFLAGS@
# extra libraries needed by X on some systems, X library location
#XLIB = -L/usr/X11R6/lib @XPM_LIBS@ -lX11
# End of common section of the Makefile
#-------------------------------------------------------------------------
working_dir=/var/bacula/working
dir_group=
dir_user=
srcdir = .
.PATH: .
topdir = .
thisdir = .
first_rule: all
dummy:
# --client-only directories
fd_subdirs = src src/lib src/findlib src/filed \
\
src/console
# Non-client-only directores
subdirs = src/cats src/dird src/stored src/tools
all_subdirs = ${fd_subdirs} ${subdirs} manpages
DIST = INSTALL README.configure configure Makefile Makefile.in ChangeLog
DIST_CFG = autoconf/aclocal.m4 autoconf/configure.in \
autoconf/config.h.in autoconf/acconfig.h autoconf/Make.common.in \
autoconf/install-sh autoconf/mkinstalldirs
MKDIR = $(srcdir)/autoconf/mkinstalldirs
#-------------------------------------------------------------------------
all: Makefile
@for I in ${all_subdirs}; \
do (cd $$I; echo "==>Entering directory `pwd`"; \
$(MAKE) $@ || (echo ""; echo ""; echo " ====== Error in `pwd` ======"; \
echo ""; echo "";)); \
done
depend:
@for I in ${all_subdirs}; \
do (cd $$I; echo "==>Entering directory `pwd`"; $(MAKE) DESTDIR=$(DESTDIR) $@ || exit 1); done
bacula-fd: Makefile
@for I in ${fd_subdirs}; \
do (cd $$I; echo "==>Entering directory `pwd`"; \
$(MAKE) all || (echo ""; echo ""; echo " ====== Error in `pwd` ======; \
echo ""; echo "";)); \
done
#-------------------------------------------------------------------------
autoconf/aclocal.m4: autoconf/configure.in autoconf/bacula-macros/* autoconf/gettext-macros/*
cd autoconf && aclocal -I bacula-macros -I gettext-macros
configure: autoconf/configure.in autoconf/aclocal.m4 autoconf/acconfig.h autoconf/config.h.in
cd $(srcdir);
${RMF} -f config.cache config.log config.out config.status src/config.h
${RMF} -rf autoconf/autom4te.cache autom4te.cache
autoconf --prepend-include=$(srcdir)/autoconf \
autoconf/configure.in > configure
chmod 755 configure
old-configure: autoconf/configure.in autoconf/aclocal.m4 autoconf/acconfig.h
cd $(srcdir);
${RMF} -f config.cache config.log config.out config.status src/config.h
autoconf --include=$(srcdir)/autoconf \
autoconf/configure.in > configure
chmod 755 configure
@rm -f config.cache
config.status:
if test -x config.status; then config.status --recheck; \
else $(SHELL) configure; fi
autoconf/config.h.in: autoconf/configure.in autoconf/acconfig.h
cd $(srcdir);
${RMF} -f config.cache config.log config.out config.status src/config.h
autoheader --prepend-include=$(srcdir)/autoconf \
autoconf/configure.in > autoconf/config.h.in
chmod 644 autoconf/config.h.in
installdirs:
$(MKDIR) $(DESTDIR)$(sbindir)
$(MKDIR) $(DESTDIR)$(sysconfdir)
$(MKDIR) $(DESTDIR)$(scriptdir)
-if test ! -d $(DESTDIR)$(working_dir) ; then \
$(MKDIR) $(DESTDIR)$(working_dir); \
chmod 770 $(DESTDIR)$(working_dir); \
fi
-if test "x$(dir_user)" != "x" ; then \
chown $(dir_user) $(DESTDIR)$(working_dir); \
fi
-if test "x$(dir_group)" != "x" ; then \
chgrp $(dir_group) $(DESTDIR)$(working_dir); \
fi
gnomedirs:
$(MKDIR) $(DESTDIR)/usr/share/pixmaps
$(MKDIR) $(DESTDIR)/usr/share/gnome/apps/System
$(MKDIR) $(DESTDIR)/usr/share/applications
$(MKDIR) $(DESTDIR)/etc/security/console.apps
$(MKDIR) $(DESTDIR)/etc/pam.d
install-menu: gnomedirs
${INSTALL_DATA} scripts/bacula.png $(DESTDIR)/usr/share/pixmaps/bacula.png
${INSTALL_DATA} scripts/bacula.desktop.gnome1 $(DESTDIR)/usr/share/gnome/apps/System/bacula.desktop
${INSTALL_DATA} scripts/bacula.desktop.gnome2 $(DESTDIR)/usr/share/applications/bacula.desktop
install-menu-xsu: gnomedirs
${INSTALL_DATA} scripts/bacula.png $(DESTDIR)/usr/share/pixmaps/bacula.png
${INSTALL_DATA} scripts/bacula.desktop.gnome1.xsu $(DESTDIR)/usr/share/gnome/apps/System/bacula.desktop
${INSTALL_DATA} scripts/bacula.desktop.gnome2.xsu $(DESTDIR)/usr/share/applications/bacula.desktop
install-menu-consolehelper: gnomedirs
${INSTALL_DATA} scripts/bacula.png $(DESTDIR)/usr/share/pixmaps/bacula.png
${INSTALL_DATA} scripts/bacula.desktop.gnome1.consolehelper $(DESTDIR)/usr/share/gnome/apps/System/bacula.desktop
${INSTALL_DATA} scripts/bacula.desktop.gnome2.consolehelper $(DESTDIR)/usr/share/applications/bacula.desktop
${INSTALL_DATA} scripts/gnome-console.console_apps $(DESTDIR)/etc/security/console.apps/gnome-console
${INSTALL_DATA} scripts/gnome-console.pamd $(DESTDIR)/etc/pam.d/gnome-console
ln -s $(DESTDIR)/usr/bin/consolehelper $(DESTDIR)/usr/bin/gnome-console
install: installdirs
@for I in $(all_subdirs); do (cd $$I && $(MAKE) DESTDIR=$(DESTDIR) $@ || exit 1); done
uninstall:
@for I in $(all_subdirs); do (cd $$I && $(MAKE) DESTDIR=$(DESTDIR) $@ || exit 1); done
install-autostart:
(cd platforms && $(MAKE) DESTDIR=$(DESTDIR) $@ || exit 1)
install-autostart-dir:
(cd platforms && $(MAKE) DESTDIR=$(DESTDIR) $@ || exit 1)
install-autostart-fd:
(cd platforms && $(MAKE) DESTDIR=$(DESTDIR) $@ || exit 1)
install-autostart-sd:
(cd platforms && $(MAKE) DESTDIR=$(DESTDIR) $@ || exit 1)
uninstall-autostart:
(cd platforms && $(MAKE) DESTDIR=$(DESTDIR) $@ || exit 1)
uninstall-autostart-dir:
(cd platforms && $(MAKE) DESTDIR=$(DESTDIR) $@ || exit 1)
uninstall-autostart-fd:
(cd platforms && $(MAKE) DESTDIR=$(DESTDIR) $@ || exit 1)
uninstall-autostart-sd:
(cd platforms && $(MAKE) DESTDIR=$(DESTDIR) $@ || exit 1)
uninstall-menu:
rm -f $(DESTDIR)/usr/share/pixmaps/bacula.png
rm -f $(DESTDIR)/usr/share/gnome/apps/System/bacula.desktop
rm -f $(DESTDIR)/usr/share/applications/bacula.desktop
uninstall-menu-consolehelper:
rm -f $(DESTDIR)/usr/share/pixmaps/bacula.png
rm -f $(DESTDIR)/usr/share/gnome/apps/System/bacula.desktop
rm -f $(DESTDIR)/usr/share/applications/bacula.desktop
rm -f $(DESTDIR)/etc/security/console.apps/gnome-console
rm -f $(DESTDIR)/etc/pam.d/gnome-console
rm -f $(DESTDIR)/usr/bin/gnome-console
Makefile: Makefile.in
cd $(topdir) \
&& CONFIG_FILES=$(thisdir)/$@ CONFIG_HEADERS= $(SHELL) ./config.status
Makefiles:
$(SHELL) config.status
(cd scripts; \
chmod 755 startmysql stopmysql bacula startit stopit btraceback; \
chmod 755 mtx-changer bconsole gconsole devel_bacula; \
chmod 755 dvd-handler)
(cd src/cats; \
chmod 755 create_bacula_database update_bacula_tables make_bacula_tables; \
chmod 755 grant_bacula_privileges drop_bacula_tables drop_bacula_database; \
chmod 755 create_bdb_database update_bdb_tables make_bdb_tables; \
chmod 755 grant_bdb_privileges drop_bdb_tables drop_bdb_database; \
chmod 755 make_catalog_backup delete_catalog_backup)
clean:
@for I in ${all_subdirs} src/win32; \
do (cd $$I; echo "==>Entering directory `pwd`"; ${MAKE} $@ || exit 1); done
@(cd platforms; echo "==>Entering directory `pwd`"; ${MAKE} $@ || exit 1)
@$(RMF) *~ 1 2 3 core core.* config.guess console.log console.sum
@$(RMF) examples/1 examples/2 examples/devices/1 examples/devices/2
@$(RMF) -r autom4te.cache
@find . -name ".#*" -exec $(RMF) {} \;
# clean for distribution
distclean:
@for I in $(all_subdirs); do (cd $$I && $(MAKE) $@ || exit 1); done
@for I in $(all_subdirs); do (cd $$I && $(RMF) startit stopit btraceback); done
@(cd $(srcdir) && $(RMF) *~ config.cache config.h config.log config.status config.out)
@(cd $(srcdir) && $(RMF) Makefile autoconf/Make.common)
@(cd platforms; echo "==>Entering directory `pwd`"; ${MAKE} $@ || exit 1)
@$(RMF) bacula fd Makefile startmysql stopmysql startit stopit btraceback
@$(RMF) bconsole gconsole
@$(RMF) *~ 1 2 3 core core.* config.guess console.log console.sum
@$(RMF) working/* kerns-*
@$(RMF) -rf txt diff src/python src/testprogs
devclean:
@for I in $(all_subdirs); do (cd $$I && $(MAKE) $@ || exit 1); done
@for I in $(all_subdirs); do (cd $$I && $(RMF) startit stopit btraceback); done
@(cd $(srcdir) && $(RMF) *~ config.cache config.h config.log config.status config.out)
@(cd $(srcdir) && $(RMF) Makefile autoconf/Make.common)
@(cd platforms; echo "==>Entering directory `pwd`"; ${MAKE} $@ || exit 1)
@$(RMF) bacula fd Makefile startmysql stopmysql startit stopit btraceback
@$(RMF) bconsole gconsole
@$(RMF) *~ 1 2 3 core core.* config.guess console.log console.sum
@$(RMF) working/*
distdirs:
mkdir ../$(VERNAME);
mkdir ../$(VERNAME)/autoconf;
@for I in $(all_subdirs); do (cd $$I && $(MAKE) DESTDIR=$(DESTDIR) $@ || (echo "Failed to make distclean in $$I"; exit 0) ); done
distcopy:
$(CP) -p $(DIST) ../$(VERNAME);
$(CP) -p $(DIST_CFG) ../$(VERNAME)/autoconf;
@for I in $(all_subdirs); do (cd $$I && $(MAKE) DESTDIR=$(DESTDIR) $@ || exit 1); done
distrib: configure autoconf/config.h.in distdirs distcopy
test:
tar.gz: ../$(VERNAME).tar.gz
../$(VERNAME).tar.gz:
(cd ..; tar cvf - $(VERNAME) | gzip -f9 > $(VERNAME).tar.gz)
tar.Z: ../$(VERNAME).tar.Z
../$(VERNAME).tar.Z:
(cd ..; tar cvf - $(VERNAME) | compress > $(VERNAME).tar.Z)
tar.bz2: ../$(VERNAME).tar.bz2
../$(VERNAME).tar.bz2:
(cd ..; tar cvf - $(VERNAME) | bzip2 -f9 > $(VERNAME).tar.bz2)
uuencode: tar.gz
uuencode ../$(VERNAME).tar.gz $(VERNAME).tar.gz > ../$(VERNAME).tgz.uu
# ------------------------------------------------------------------------
syntax highlighted by Code2HTML, v. 0.9.1