#
#
#
# This file is pulled in by all the Unix Bacula Makefiles
# so it has all the "common" definitions
#
DATE="10 November 2007"
LSMDATE=10Nov07
VERSION=2.2.6
VERNAME=bacula-$(VERSION)#
MAINT=Kern Sibbald#
MAINTEMAIL=<kern@sibbald.com>#
WEBMAINT=#
WEBMAINTEMAIL=#
WEBPAGE=#
FTPSITENAME=#
FTPSITEDIR=#
#-------------------------------------------------------------------------
SHELL = /bin/sh
# Installation target directories & other installation stuff
prefix =
exec_prefix =
binprefix =
manprefix =
sbindir = /sbin
sysconfdir = /etc
scriptdir = /etc
mandir = /usr/share/man
manext = 8
NO_ECHO = @
# Tools & program stuff
CC = cc
CPP = cc -E
CXX = /usr/bin/c++
MV = /usr/local/bin/mv
RM = /usr/local/bin/rm
RMF = /usr/local/bin/rm -f
CP = /usr/local/bin/cp
SED = /usr/local/bin/sed
AWK = /usr/local/bin/gawk
ECHO = /usr/local/bin/echo
CMP = /usr/bin/cmp
TBL = /usr/bin/tbl
AR = /usr/bin/ar
RANLIB = ranlib
MKDIR = /mnt/gmirror/ports/sysutils/bacula-client/work/bacula-2.2.6/autoconf/mkinstalldirs
INSTALL = /usr/bin/install -c -o root -g wheel
# add the -s to the following in PRODUCTION mode
INSTALL_PROGRAM = /usr/bin/install -c -o root -g wheel -m 0754
INSTALL_DATA = /usr/bin/install -c -o root -g wheel -m 644
INSTALL_SCRIPT = /usr/bin/install -c -o root -g wheel -m 0754
INSTALL_CONFIG = /usr/bin/install -c -o root -g wheel -m 640
# Flags & libs
CFLAGS = -fno-common
CPPFLAGS = -I/usr/include/readline -I/usr/local/include
LDFLAGS = -L/usr/local/lib
TTOOL_LDFLAGS =
#DEFS = -DHAVE_CONFIG_H
LIBS = -lpthread -lintl
WRAPLIBS =
DINCLUDE =
DLIB =
DB_LIBS =
PYTHON_LIBS =
PYTHON_INC =
OPENSSL_LIBS =
# Windows (cygwin) flags
WCFLAGS =
WLDFLAGS =
# X Include directory
#XINC = -I/usr/X11R6/include @XPM_CFLAGS@
# extra libraries needed by X on some systems, X library location
#XLIB = -L/usr/X11R6/lib @XPM_LIBS@ -lX11
# End of common section of the Makefile
#-------------------------------------------------------------------------
.PHONY: dummy
MAN8 = bacula.8 bacula-dir.8 bacula-fd.8 bacula-sd.8 \
bconsole.8 bcopy.8 bextract.8 bls.8 bscan.8 btape.8 \
btraceback.8 dbcheck.8
MAN1 = bacula-bgnome-console.1 bacula-tray-monitor.1 \
bacula-bwxconsole.1 bsmtp.1 bat.1
all:
nothing:
depend:
install:
$(MKDIR) $(DESTDIR)/$(mandir)/man8
for I in ${MAN8}; \
do ($(RMF) $$I.gz; gzip -c $$I >$$I.gz; \
$(INSTALL_DATA) $$I.gz $(DESTDIR)$(mandir)/man8/$$I.gz; \
rm -f $$I.gz); \
done
$(MKDIR) $(DESTDIR)/$(mandir)/man1
for I in ${MAN1}; \
do ($(RMF) $$I.gz; gzip -c $$I >$$I.gz; \
$(INSTALL_DATA) $$I.gz $(DESTDIR)$(mandir)/man1/$$I.gz; \
rm -f $$I.gz); \
done
uninstall:
for I in ${MAN8}; \
do (rm -f $(DESTDIR)$(mandir)/man8/$$I.gz); \
done
for I in ${MAN1}; \
do (rm -f $(DESTDIR)$(mandir)/man1/$$I.gz); \
done
clean: dummy
$(RMF) *~ 1 2 3 *.bak
@find . -name .#* -exec $(RMF) {} \;
depend:
distclean: clean
$(RMF) Makefile
syntax highlighted by Code2HTML, v. 0.9.1