# 
# This file is used as the template to create the
# Makefile for the SuSe specific installation.
#
#
#  for Bacula release @VERSION@ (@DATE@) -- @DISTNAME@
#

INSTALL = @INSTALL@
INSTALL_PROGRAM = @INSTALL_PROGRAM@

nothing:

install: install-autostart

install-autostart: install-autostart-fd install-autostart-sd install-autostart-dir

	
install-autostart-fd:
	@if test x$(DESTDIR) = x -a  -f /etc/init.d/bacula-fd; then \
	   /sbin/chkconfig --del bacula-fd; \
	fi
	@$(INSTALL_PROGRAM) -m 744 bacula-fd $(DESTDIR)/etc/init.d/bacula-fd
	# set symlinks for script at startup and shutdown
	@if test x$(DESTDIR) = x ; then \
	   /sbin/chkconfig --add bacula-fd; \
	fi


install-autostart-sd:
	@if test x$(DESTDIR) = x -a  -f /etc/init.d/bacula-sd; then \
	    /sbin/chkconfig --del bacula-sd; \
	fi
	@$(INSTALL_PROGRAM) -m 744 bacula-sd  $(DESTDIR)/etc/init.d/bacula-sd
	# set symlinks for script at startup and shutdown
	@if test x$(DESTDIR) = x ; then \
	   /sbin/chkconfig --add bacula-sd; \
	fi


install-autostart-dir:
	@if test x$(DESTDIR) = x -a  -f /etc/init.d/bacula-dir; then \
	    /sbin/chkconfig --del bacula-dir; \
	fi
	@$(INSTALL_PROGRAM) -m 744 bacula-dir  $(DESTDIR)/etc/init.d/bacula-dir
	# set symlinks for script at startup and shutdown
	@if test x$(DESTDIR) = x ; then \
	   /sbin/chkconfig --add bacula-dir; \
	fi


uninstall: uninstall-autostart

uninstall-autostart: uninstall-autostart-fd uninstall-autostart-sd uninstall-autostart-dir

uninstall-autostart-fd:
	@if test x$(DESTDIR) = x -a  -f /etc/init.d/bacula-fd; then \
	    /sbin/chkconfig --del bacula-fd; \
	fi
	@rm -f	$(DESTDIR)/etc/init.d/bacula-fd


uninstall-autostart-sd:
	@if test x$(DESTDIR) = x -a  -f /etc/init.d/bacula-sd; then \
	    /sbin/chkconfig --del bacula-sd; \
	fi
	@rm -f	$(DESTDIR)/etc/init.d/bacula-sd

uninstall-autostart-dir:
	@if test x$(DESTDIR) = x -a  -f /etc/init.d/bacula-dir; then \
	    /sbin/chkconfig --del bacula-dir; \
	fi
	@rm -f	$(DESTDIR)/etc/init.d/bacula-dir

clean:
	@rm -f 1 2 3

distclean: clean
	@rm -f Makefile bacula-*.spec bacula.*.spec bacula.spec
	@rm -f bacula-sd bacula-fd bacula-dir

devclean: clean
	@rm -f Makefile bacula-*.spec bacula.*.spec bacula.spec
	@rm -f bacula-sd bacula-fd bacula-dir


syntax highlighted by Code2HTML, v. 0.9.1