# 
# Version $Id: Makefile.in 4567 2007-04-18 17:06:43Z kerns $
# 

#
# This file is pulled in by all the Unix Bacula Makefiles
#   so it has all the "common" definitions
#

DATE="10 November 2007"
LSMDATE=10Nov07
VERSION=2.2.6
VERNAME=bacula-$(VERSION)#
MAINT=Kern Sibbald#
MAINTEMAIL=<kern@sibbald.com>#
WEBMAINT=#
WEBMAINTEMAIL=#
WEBPAGE=#
FTPSITENAME=#
FTPSITEDIR=#
#-------------------------------------------------------------------------

SHELL = /bin/sh

# Installation target directories & other installation stuff
prefix = 
exec_prefix = 
binprefix =
manprefix =
sbindir = /sbin
sysconfdir = /etc
scriptdir = /etc
mandir = /usr/share/man
manext = 8

NO_ECHO = @

# Tools & program stuff
CC = cc
CPP = cc -E
CXX = /usr/bin/c++
MV = /usr/local/bin/mv
RM = /usr/local/bin/rm
RMF = /usr/local/bin/rm -f
CP = /usr/local/bin/cp
SED = /usr/local/bin/sed
AWK = /usr/local/bin/gawk
ECHO = /usr/local/bin/echo
CMP = /usr/bin/cmp
TBL = /usr/bin/tbl
AR = /usr/bin/ar
RANLIB = ranlib
MKDIR = /mnt/gmirror/ports/sysutils/bacula-client/work/bacula-2.2.6/autoconf/mkinstalldirs
INSTALL = /usr/bin/install -c -o root -g wheel
# add the -s to the following in PRODUCTION mode
INSTALL_PROGRAM = /usr/bin/install -c -o root -g wheel -m 0754
INSTALL_DATA = /usr/bin/install -c -o root -g wheel -m 644
INSTALL_SCRIPT = /usr/bin/install -c -o root -g wheel -m 0754
INSTALL_CONFIG = /usr/bin/install -c -o root -g wheel -m 640

# Flags & libs
CFLAGS = -fno-common 
CPPFLAGS = -I/usr/include/readline -I/usr/local/include 
LDFLAGS = -L/usr/local/lib
TTOOL_LDFLAGS = 
#DEFS = -DHAVE_CONFIG_H 
LIBS = -lpthread  -lintl
WRAPLIBS = 
DINCLUDE = 
DLIB = 
DB_LIBS = 
PYTHON_LIBS = 
PYTHON_INC = 
OPENSSL_LIBS = 

# Windows (cygwin) flags 
WCFLAGS = 
WLDFLAGS = 

# X Include directory
#XINC =  -I/usr/X11R6/include @XPM_CFLAGS@

# extra libraries needed by X on some systems, X library location
#XLIB =  -L/usr/X11R6/lib @XPM_LIBS@ -lX11 

# End of common section of the Makefile
#-------------------------------------------------------------------------

working_dir=/var/bacula/working

srcdir =	.

.PATH:		.
topdir = ..
thisdir = scripts


first_rule: all
dummy:

MKDIR = $(topdir)/autoconf/mkinstalldirs

#-------------------------------------------------------------------------

all: Makefile

depend:
	

#-------------------------------------------------------------------------

installdirs:
	$(MKDIR) $(DESTDIR)$(sysconfdir)
	$(MKDIR) $(DESTDIR)$(sbindir)
	$(MKDIR) $(DESTDIR)$(scriptdir)
	$(MKDIR) $(DESTDIR)$(mandir)

install: installdirs
	$(INSTALL_SCRIPT) bconsole $(DESTDIR)$(scriptdir)/bconsole
	$(INSTALL_SCRIPT) gconsole $(DESTDIR)$(scriptdir)/gconsole
	$(INSTALL_SCRIPT) bacula $(DESTDIR)$(scriptdir)/bacula
	$(INSTALL_SCRIPT) bacula-ctl-dir $(DESTDIR)$(scriptdir)/bacula-ctl-dir
	$(INSTALL_SCRIPT) bacula-ctl-fd $(DESTDIR)$(scriptdir)/bacula-ctl-fd
	$(INSTALL_SCRIPT) bacula-ctl-sd $(DESTDIR)$(scriptdir)/bacula-ctl-sd
	@if  test -f ${DESTDIR}${scriptdir}/mtx-changer; then \
	   echo "  ==> Saving existing mtx-changer to mtx-changer.old"; \
	   $(MV) -f ${DESTDIR}${scriptdir}/mtx-changer ${DESTDIR}${scriptdir}/mtx-changer.old; \
	fi
	$(INSTALL_SCRIPT) mtx-changer $(DESTDIR)$(scriptdir)/mtx-changer
	@if  test -f ${DESTDIR}${scriptdir}/disk-changer; then \
	   echo "  ==> Saving existing disk-changer to disk-changer.old"; \
	   $(MV) -f ${DESTDIR}${scriptdir}/disk-changer ${DESTDIR}${scriptdir}/disk-changer.old; \
	fi
	$(INSTALL_SCRIPT) disk-changer $(DESTDIR)$(scriptdir)/disk-changer
	@if  test -f ${DESTDIR}${scriptdir}/dvd-handler; then \
	   echo "  ==> Saving existing dvd-handler to dvd-handler.old"; \
	   $(MV) -f ${DESTDIR}${scriptdir}/dvd-handler ${DESTDIR}${scriptdir}/dvd-handler.old; \
	fi
	$(INSTALL_SCRIPT) dvd-handler $(DESTDIR)$(scriptdir)/dvd-handler
	$(INSTALL_DATA)   btraceback.gdb $(DESTDIR)$(scriptdir)/btraceback.gdb
	$(INSTALL_DATA)   btraceback.dbx $(DESTDIR)$(scriptdir)/btraceback.dbx
	chmod 0644 $(DESTDIR)$(scriptdir)/btraceback.gdb \
		   $(DESTDIR)$(scriptdir)/btraceback.dbx
	$(INSTALL_SCRIPT) btraceback $(DESTDIR)$(sbindir)/btraceback


uninstall:
	(cd $(DESTDIR)$(scriptdir); $(RMF) startmysql)
	(cd $(DESTDIR)$(scriptdir); $(RMF) stopmysql)
	(cd $(DESTDIR)$(scriptdir); $(RMF) bconsole)
	(cd $(DESTDIR)$(scriptdir); $(RMF) gconsole)
	(cd $(DESTDIR)$(scriptdir); $(RMF) bacula)
	(cd $(DESTDIR)$(scriptdir); $(RMF) bacula-ctl-dir)
	(cd $(DESTDIR)$(scriptdir); $(RMF) bacula-ctl-fd)
	(cd $(DESTDIR)$(scriptdir); $(RMF) bacula-ctl-sd)
	(cd $(DESTDIR)$(scriptdir); $(RMF) fd)
	(cd $(DESTDIR)$(scriptdir); $(RMF) mtx-changer)
	(cd $(DESTDIR)$(scriptdir); $(RMF) disk-changer)
	(cd $(DESTDIR)$(scriptdir); $(RMF) dvd-handler)  
	(cd $(DESTDIR)$(scriptdir); $(RMF) btraceback.gdb)
	(cd $(DESTDIR)$(scriptdir); $(RMF) btraceback.dbx)
	(cd $(DESTDIR)$(sbindir); $(RMF) btraceback)

Makefile: Makefile.in
	cd $(topdir) \
	    && CONFIG_FILES=$(thisdir)/$@ CONFIG_HEADERS= $(SHELL) ./config.status
	chmod 755 startmysql stopmysql bacula startit stopit btraceback
	chmod 755 bacula-ctl-dir bacula-ctl-fd bacula-ctl-sd
	chmod 755 disk-changer mtx-changer dvd-handler bconsole gconsole

Makefiles:
	$(SHELL) config.status
	chmod 755 startmysql stopmysql bacula startit stopit btraceback
	chmod 755 bacula-ctl-dir bacula-ctl-fd bacula-ctl-sd
	chmod 755 mtx-changer dvd-handler bconsole gconsole

clean:
	@$(RMF) *~ 1 2 3

# clean for distribution
distclean: clean
	@$(RMF) startmysql stopmysql bacula fd startit stopit btraceback
	@$(RMF) bacula-ctl-dir bacula-ctl-fd bacula-ctl-sd
	@$(RMF) bconsole gconsole logrotate bacula.desktop 
	@$(RMF) bacula.desktop.gnome1 bacula.desktop.gnome2 mtx-changer dvd-handler
	@$(RMF) gnome-console.console_apps bacula.desktop.gnome2.xsu
	@$(RMF) bgnome-console.console_apps
	@$(RMF) bacula.desktop.gnome2.consolehelper bacula.desktop.gnome1.xsu
	@$(RMF) bacula.desktop.gnome1.consolehelper

# ------------------------------------------------------------------------


syntax highlighted by Code2HTML, v. 0.9.1