#
# Version $Id: Makefile.in 4914 2007-05-27 09:34:40Z kerns $
#
#
# This file is pulled in by all the Unix Bacula Makefiles
# so it has all the "common" definitions
#
DATE="10 November 2007"
LSMDATE=10Nov07
VERSION=2.2.6
VERNAME=bacula-$(VERSION)#
MAINT=Kern Sibbald#
MAINTEMAIL=<kern@sibbald.com>#
WEBMAINT=#
WEBMAINTEMAIL=#
WEBPAGE=#
FTPSITENAME=#
FTPSITEDIR=#
#-------------------------------------------------------------------------
SHELL = /bin/sh
# Installation target directories & other installation stuff
prefix =
exec_prefix =
binprefix =
manprefix =
sbindir = /sbin
sysconfdir = /etc
scriptdir = /etc
mandir = /usr/share/man
manext = 8
NO_ECHO = @
# Tools & program stuff
CC = cc
CPP = cc -E
CXX = /usr/bin/c++
MV = /usr/local/bin/mv
RM = /usr/local/bin/rm
RMF = /usr/local/bin/rm -f
CP = /usr/local/bin/cp
SED = /usr/local/bin/sed
AWK = /usr/local/bin/gawk
ECHO = /usr/local/bin/echo
CMP = /usr/bin/cmp
TBL = /usr/bin/tbl
AR = /usr/bin/ar
RANLIB = ranlib
MKDIR = /mnt/gmirror/ports/sysutils/bacula-client/work/bacula-2.2.6/autoconf/mkinstalldirs
INSTALL = /usr/bin/install -c -o root -g wheel
# add the -s to the following in PRODUCTION mode
INSTALL_PROGRAM = /usr/bin/install -c -o root -g wheel -m 0754
INSTALL_DATA = /usr/bin/install -c -o root -g wheel -m 644
INSTALL_SCRIPT = /usr/bin/install -c -o root -g wheel -m 0754
INSTALL_CONFIG = /usr/bin/install -c -o root -g wheel -m 640
# Flags & libs
CFLAGS = -fno-common
CPPFLAGS = -I/usr/include/readline -I/usr/local/include
LDFLAGS = -L/usr/local/lib
TTOOL_LDFLAGS =
#DEFS = -DHAVE_CONFIG_H
LIBS = -lpthread -lintl
WRAPLIBS =
DINCLUDE =
DLIB =
DB_LIBS =
PYTHON_LIBS =
PYTHON_INC =
OPENSSL_LIBS =
# Windows (cygwin) flags
WCFLAGS =
WLDFLAGS =
# X Include directory
#XINC = -I/usr/X11R6/include @XPM_CFLAGS@
# extra libraries needed by X on some systems, X library location
#XLIB = -L/usr/X11R6/lib @XPM_LIBS@ -lX11
# End of common section of the Makefile
#-------------------------------------------------------------------------
srcdir = .
VPATH = .
.PATH: .
# one up
basedir = ..
# top dir
topdir = ../..
# this dir relative to top dir
thisdir = src/console
DEBUG=
first_rule: all
dummy:
#
CONSSRCS = console.c console_conf.c authenticate.c
CONSOBJS = console.o console_conf.o authenticate.o
# these are the objects that are changed by the .configure process
EXTRAOBJS =
GETTEXT_LIBS =
CONS_INC=-I/usr/include/readline
CONS_LIBS=-lreadline -ltermcap
CONS_LDFLAGS=
.SUFFIXES: .c .o
.PHONY:
.DONTCARE:
# inference rules
.c.o:
@echo "Compiling $<"
$(NO_ECHO)$(CXX) $(DEFS) $(DEBUG) -c $(CPPFLAGS) $(CONS_INC) -I$(srcdir) -I$(basedir) $(DINCLUDE) $(CFLAGS) $<
#-------------------------------------------------------------------------
all: Makefile bconsole
@echo "==== Make of console is good ===="
@echo " "
bconsole: $(CONSOBJS) ../lib/libbac.a
$(CXX) $(LDFLAGS) $(CONS_LDFLAGS) -L../lib -L../cats -o $@ $(CONSOBJS) \
$(DLIB) $(CONS_LIBS) -lbac -lm $(LIBS) $(GETTEXT_LIBS) \
$(OPENSSL_LIBS)
static-bconsole: $(CONSOBJS) ../lib/libbac.a
$(CXX) -static $(LDFLAGS) $(CONS_LDFLAGS) -L../lib -L../cats -o $@ $(CONSOBJS) \
$(DLIB) $(CONS_LIBS) -lbac -lm $(LIBS) $(GETTEXT_LIBS) \
$(OPENSSL_LIBS)
strip $@
Makefile: $(srcdir)/Makefile.in $(topdir)/config.status
cd $(topdir) \
&& CONFIG_FILES=$(thisdir)/$@ CONFIG_HEADERS= $(SHELL) ./config.status
clean:
@$(RMF) console bconsole core core.* a.out *.o *.bak *~ *.intpro *.extpro 1 2 3
@$(RMF) static-console static-bconsole gmon.out
realclean: clean
@$(RMF) tags console.conf bconsole.conf
distclean: realclean
if test $(srcdir) = .; then $(MAKE) realclean; fi
(cd $(srcdir); $(RMF) Makefile)
devclean: realclean
if test $(srcdir) = .; then $(MAKE) realclean; fi
(cd $(srcdir); $(RMF) Makefile)
install: all
@if test -f ${DESTDIR}${sbindir}/console; then \
echo " "; \
echo "Warning!!! ${DESTDIR}${sbindir}console found."; \
echo " console has been renamed bconsole, so console"; \
echo " is no longer used, and you might want to delete it."; \
echo " "; \
fi
$(INSTALL_PROGRAM) bconsole $(DESTDIR)$(sbindir)/bconsole
@srcconf=bconsole.conf; \
if test -f ${DESTDIR}${sysconfdir}/$$srcconf; then \
destconf=$$srcconf.new; \
echo " ==> Found existing $$srcconf, installing new conf file as $$destconf"; \
else \
destconf=$$srcconf; \
if test -f ${DESTDIR}${sysconfdir}/console.conf; then \
echo "Existing console.conf moved to bconsole.conf"; \
$(MV) ${DESTDIR}${sysconfdir}/console.conf ${DESTDIR}${sysconfdir}/bconsole.conf; \
destconf=$$srcconf.new; \
fi; \
fi; \
echo "${INSTALL_CONFIG} $$srcconf ${DESTDIR}${sysconfdir}/$$destconf"; \
${INSTALL_CONFIG} $$srcconf ${DESTDIR}${sysconfdir}/$$destconf
if test -f static-bconsole; then \
$(INSTALL_PROGRAM) static-bconsole $(DESTDIR)$(sbindir)/static-bconsole; \
fi
uninstall:
(cd $(DESTDIR)$(sbindir); $(RMF) bconsole static-bconsole)
(cd $(DESTDIR)$(sysconfdir); $(RMF) console.conf bconsole.conf bconsole.conf.new)
# Semi-automatic generation of dependencies:
# Use gcc -MM because X11 `makedepend' doesn't work on all systems
# and it also includes system headers.
# `semi'-automatic since dependencies are generated at distribution time.
depend:
@$(MV) Makefile Makefile.bak
@$(SED) "/^# DO NOT DELETE:/,$$ d" Makefile.bak > Makefile
@$(ECHO) "# DO NOT DELETE: nice dependency list follows" >> Makefile
@$(CXX) -S -M $(CPPFLAGS) $(CONS_INC) -I$(srcdir) -I$(basedir) *.c >> Makefile
@if test -f Makefile ; then \
$(RMF) Makefile.bak; \
else \
$(MV) Makefile.bak Makefile; \
echo " ===== Something went wrong in make depend ====="; \
fi
# -----------------------------------------------------------------------
# DO NOT DELETE: nice dependency list follows
syntax highlighted by Code2HTML, v. 0.9.1