#
# Version $Id: Makefile.in 4914 2007-05-27 09:34:40Z kerns $
#
#
# This file is pulled in by all the Unix Bacula Makefiles
# so it has all the "common" definitions
#
DATE="10 November 2007"
LSMDATE=10Nov07
VERSION=2.2.6
VERNAME=bacula-$(VERSION)#
MAINT=Kern Sibbald#
MAINTEMAIL=<kern@sibbald.com>#
WEBMAINT=#
WEBMAINTEMAIL=#
WEBPAGE=#
FTPSITENAME=#
FTPSITEDIR=#
#-------------------------------------------------------------------------
SHELL = /bin/sh
# Installation target directories & other installation stuff
prefix =
exec_prefix =
binprefix =
manprefix =
sbindir = /sbin
sysconfdir = /etc
scriptdir = /etc
mandir = /usr/share/man
manext = 8
NO_ECHO = @
# Tools & program stuff
CC = cc
CPP = cc -E
CXX = /usr/bin/c++
MV = /usr/local/bin/mv
RM = /usr/local/bin/rm
RMF = /usr/local/bin/rm -f
CP = /usr/local/bin/cp
SED = /usr/local/bin/sed
AWK = /usr/local/bin/gawk
ECHO = /usr/local/bin/echo
CMP = /usr/bin/cmp
TBL = /usr/bin/tbl
AR = /usr/bin/ar
RANLIB = ranlib
MKDIR = /mnt/gmirror/ports/sysutils/bacula-client/work/bacula-2.2.6/autoconf/mkinstalldirs
INSTALL = /usr/bin/install -c -o root -g wheel
# add the -s to the following in PRODUCTION mode
INSTALL_PROGRAM = /usr/bin/install -c -o root -g wheel -m 0754
INSTALL_DATA = /usr/bin/install -c -o root -g wheel -m 644
INSTALL_SCRIPT = /usr/bin/install -c -o root -g wheel -m 0754
INSTALL_CONFIG = /usr/bin/install -c -o root -g wheel -m 640
# Flags & libs
CFLAGS = -fno-common
CPPFLAGS = -I/usr/include/readline -I/usr/local/include
LDFLAGS = -L/usr/local/lib
TTOOL_LDFLAGS =
#DEFS = -DHAVE_CONFIG_H
LIBS = -lpthread -lintl
WRAPLIBS =
DINCLUDE =
DLIB =
DB_LIBS =
PYTHON_LIBS =
PYTHON_INC =
OPENSSL_LIBS =
# Windows (cygwin) flags
WCFLAGS =
WLDFLAGS =
# X Include directory
#XINC = -I/usr/X11R6/include @XPM_CFLAGS@
# extra libraries needed by X on some systems, X library location
#XLIB = -L/usr/X11R6/lib @XPM_LIBS@ -lX11
# End of common section of the Makefile
#-------------------------------------------------------------------------
srcdir = .
VPATH = .
.PATH: .
# one up
basedir = ..
# top dir
topdir = ../..
# this dir relative to top dir
thisdir = src/wx-console
DEBUG=
first_rule: all
dummy:
#
CONSSRCS = main.cpp console_thread.cpp authenticate.c console_conf.c wxbrestorepanel.cpp \
wxbmainframe.cpp wxbtableparser.cpp wxbtreectrl.cpp wxblistctrl.cpp wxbutils.cpp \
wxbconfigpanel.cpp wxbconfigfileeditor.cpp wxbhistorytextctrl.cpp
CONSOBJS = main.o console_thread.o authenticate.o console_conf.o wxbrestorepanel.o \
wxbmainframe.o wxbtableparser.o wxbtreectrl.o wxblistctrl.o wxbutils.o \
wxbconfigpanel.o wxbconfigfileeditor.o wxbhistorytextctrl.o
win32 = bwx-console_private.res
WIN32RES = $()
macosx = bwx-console.app
MACOSXAPP = $(macosx)
# these are the objects that are changed by the .configure process
EXTRAOBJS =
macosx_cppflags = -DHAVE_MACOSX -DNO_GCC_PRAGMA
_cppflags =
# wx-config generated by configure
CONS_CPPFLAGS=-DHAVE_WXCONSOLE $(macosx_cppflags)
CONS_LDFLAGS=
.SUFFIXES: .cpp .c .o
.PHONY:
.DONTCARE:
# inference rules
.c.o:
@echo "Compiling $<"
$(NO_ECHO)$(CXX) $(DEFS) $(DEBUG) -c $(CPPFLAGS) $(CONS_CPPFLAGS) $(CONS_INC) \
-I$(srcdir) -I$(basedir) $(DINCLUDE) $(WCFLAGS) $(CFLAGS) $<
.cpp.o:
@echo "Compiling $<"
$(NO_ECHO)$(CXX) $(DEFS) $(DEBUG) -c $(CPPFLAGS) $(CONS_CPPFLAGS) $(CONS_INC) \
-I$(srcdir) -I$(basedir) $(DINCLUDE) $(WCFLAGS) $(CFLAGS) $<
#-------------------------------------------------------------------------
all: Makefile bwx-console $(MACOSXAPP)
@echo "==== Make of wx-console is good ===="
@echo " "
# Mac OS X application bundle
# See http://216.239.59.104/search?q=cache:a61SGKgoHSQJ:wiki.wxwidgets.org/wiki.pl%3FWxMac_Issues+wxmac+%22application+bundle%22&hl=fr
bwx-console.app: bwx-console
-mkdir bwx-console.app
-mkdir bwx-console.app/Contents
-mkdir bwx-console.app/Contents/MacOS
-mkdir bwx-console.app/Contents/Resources
-mkdir bwx-console.app/Contents/Resources/English.lproj
echo -n 'APPL????' > bwx-console.app/Contents/PkgInfo
mv bwx-console bwx-console.app/Contents/MacOS/bwx-console
cp bwx-console.conf /Library/Preferences/org.bacula.wxconsole.conf
bwx-console: $(CONSOBJS) ../lib/libbac.a
$(CXX) $(CONSOBJS) $(WIN32RES) -o $@ $(LIBS) -L../lib $(CONS_LDFLAGS) \
-lbac $(OPENSSL_LIBS)
win32: bwx-console_private.res
bwx-console_private.res: bwx-console_private.rc
windres.exe -i bwx-console_private.rc -I rc -o bwx-console_private.res -O coff
clean:
@$(RMF) $(CONSOBJS) bwx-console $(WIN32RES)
distclean: clean
$(RMF) Makefile
Makefile: $(srcdir)/Makefile.in $(topdir)/config.status
cd $(topdir) \
&& CONFIG_FILES=$(thisdir)/$@ CONFIG_HEADERS= $(SHELL) ./config.status
install: all
@if test -f ${DESTDIR}${sbindir}/wx-console; then \
echo " "; \
echo "Warning!!! ${DESTDIR}${sbindir}wx-console found."; \
echo " wx-console has been renamed bwx-console, so wx-console"; \
echo " is no longer used, and you might want to delete it."; \
echo " "; \
fi
$(INSTALL_PROGRAM) bwx-console $(DESTDIR)$(sbindir)/bwx-console
@srcconf=bwx-console.conf; \
if test -f ${DESTDIR}${sysconfdir}/$$srcconf; then \
destconf=$$srcconf.new; \
echo " ==> Found existing $$srcconf, installing new conf file as $$destconf"; \
else \
destconf=$$srcconf; \
fi; \
echo "${INSTALL_CONFIG} $$srcconf ${DESTDIR}${sysconfdir}/$$destconf"; \
${INSTALL_CONFIG} $$srcconf ${DESTDIR}${sysconfdir}/$$destconf
uninstall:
(cd $(DESTDIR)$(sbindir); $(RMF) bwx-console)
(cd $(DESTDIR)$(sysconfdir); $(RMF) bwx-console.conf bwx-console.conf.new)
# Semi-automatic generation of dependencies:
# Use gcc -MM because X11 `makedepend' doesn't work on all systems
# and it also includes system headers.
# `semi'-automatic since dependencies are generated at distribution time.
depend:
@$(MV) Makefile Makefile.bak
@$(SED) "/^# DO NOT DELETE:/,$$ d" Makefile.bak > Makefile
@$(ECHO) "# DO NOT DELETE: nice dependency list follows" >> Makefile
@$(CXX) -S -M $(CPPFLAGS) $(CONS_CPPFLAGS) -I$(srcdir) -I$(basedir) $(CONSSRCS) >> Makefile
@if test -f Makefile ; then \
$(RMF) Makefile.bak; \
else \
$(MV) Makefile.bak Makefile; \
echo " ===== Something went wrong in make depend ====="; \
fi
# -----------------------------------------------------------------------
# DO NOT DELETE: nice dependency list follows
syntax highlighted by Code2HTML, v. 0.9.1