#
# Version $Id: Makefile.in 4914 2007-05-27 09:34:40Z kerns $
#
@MCOMMON@
srcdir = .
VPATH = .
.PATH: .
# one up
basedir = ..
# top dir
topdir = ../..
# this dir relative to top dir
thisdir = src/wx-console
DEBUG=@DEBUG@
first_rule: all
dummy:
#
CONSSRCS = main.cpp console_thread.cpp authenticate.c console_conf.c wxbrestorepanel.cpp \
wxbmainframe.cpp wxbtableparser.cpp wxbtreectrl.cpp wxblistctrl.cpp wxbutils.cpp \
wxbconfigpanel.cpp wxbconfigfileeditor.cpp wxbhistorytextctrl.cpp
CONSOBJS = main.o console_thread.o authenticate.o console_conf.o wxbrestorepanel.o \
wxbmainframe.o wxbtableparser.o wxbtreectrl.o wxblistctrl.o wxbutils.o \
wxbconfigpanel.o wxbconfigfileeditor.o wxbhistorytextctrl.o
win32 = bwx-console_private.res
WIN32RES = $(@WIN32@)
macosx = bwx-console.app
MACOSXAPP = $(@MACOSX@)
# these are the objects that are changed by the .configure process
EXTRAOBJS = @OBJLIST@
macosx_cppflags = -DHAVE_MACOSX -DNO_GCC_PRAGMA
_cppflags =
# wx-config generated by configure
CONS_CPPFLAGS=-DHAVE_WXCONSOLE @WXCONS_CPPFLAGS@ $(@MACOSX@_cppflags)
CONS_LDFLAGS=@WXCONS_LDFLAGS@
.SUFFIXES: .cpp .c .o
.PHONY:
.DONTCARE:
# inference rules
.c.o:
@echo "Compiling $<"
$(NO_ECHO)$(CXX) $(DEFS) $(DEBUG) -c $(CPPFLAGS) $(CONS_CPPFLAGS) $(CONS_INC) \
-I$(srcdir) -I$(basedir) $(DINCLUDE) $(WCFLAGS) $(CFLAGS) $<
.cpp.o:
@echo "Compiling $<"
$(NO_ECHO)$(CXX) $(DEFS) $(DEBUG) -c $(CPPFLAGS) $(CONS_CPPFLAGS) $(CONS_INC) \
-I$(srcdir) -I$(basedir) $(DINCLUDE) $(WCFLAGS) $(CFLAGS) $<
#-------------------------------------------------------------------------
all: Makefile bwx-console $(MACOSXAPP)
@echo "==== Make of wx-console is good ===="
@echo " "
# Mac OS X application bundle
# See http://216.239.59.104/search?q=cache:a61SGKgoHSQJ:wiki.wxwidgets.org/wiki.pl%3FWxMac_Issues+wxmac+%22application+bundle%22&hl=fr
bwx-console.app: bwx-console
-mkdir bwx-console.app
-mkdir bwx-console.app/Contents
-mkdir bwx-console.app/Contents/MacOS
-mkdir bwx-console.app/Contents/Resources
-mkdir bwx-console.app/Contents/Resources/English.lproj
echo -n 'APPL????' > bwx-console.app/Contents/PkgInfo
mv bwx-console bwx-console.app/Contents/MacOS/bwx-console
cp bwx-console.conf /Library/Preferences/org.bacula.wxconsole.conf
bwx-console: $(CONSOBJS) @WIN32@ ../lib/libbac.a
$(CXX) $(CONSOBJS) $(WIN32RES) -o $@ $(LIBS) -L../lib $(CONS_LDFLAGS) \
-lbac $(OPENSSL_LIBS)
win32: bwx-console_private.res
bwx-console_private.res: bwx-console_private.rc
windres.exe -i bwx-console_private.rc -I rc -o bwx-console_private.res -O coff
clean:
@$(RMF) $(CONSOBJS) bwx-console $(WIN32RES)
distclean: clean
$(RMF) Makefile
Makefile: $(srcdir)/Makefile.in $(topdir)/config.status
cd $(topdir) \
&& CONFIG_FILES=$(thisdir)/$@ CONFIG_HEADERS= $(SHELL) ./config.status
install: all
@if test -f ${DESTDIR}${sbindir}/wx-console; then \
echo " "; \
echo "Warning!!! ${DESTDIR}${sbindir}wx-console found."; \
echo " wx-console has been renamed bwx-console, so wx-console"; \
echo " is no longer used, and you might want to delete it."; \
echo " "; \
fi
$(INSTALL_PROGRAM) bwx-console $(DESTDIR)$(sbindir)/bwx-console
@srcconf=bwx-console.conf; \
if test -f ${DESTDIR}${sysconfdir}/$$srcconf; then \
destconf=$$srcconf.new; \
echo " ==> Found existing $$srcconf, installing new conf file as $$destconf"; \
else \
destconf=$$srcconf; \
fi; \
echo "${INSTALL_CONFIG} $$srcconf ${DESTDIR}${sysconfdir}/$$destconf"; \
${INSTALL_CONFIG} $$srcconf ${DESTDIR}${sysconfdir}/$$destconf
uninstall:
(cd $(DESTDIR)$(sbindir); $(RMF) bwx-console)
(cd $(DESTDIR)$(sysconfdir); $(RMF) bwx-console.conf bwx-console.conf.new)
# Semi-automatic generation of dependencies:
# Use gcc -MM because X11 `makedepend' doesn't work on all systems
# and it also includes system headers.
# `semi'-automatic since dependencies are generated at distribution time.
depend:
@$(MV) Makefile Makefile.bak
@$(SED) "/^# DO NOT DELETE:/,$$ d" Makefile.bak > Makefile
@$(ECHO) "# DO NOT DELETE: nice dependency list follows" >> Makefile
@$(CXX) -S -M $(CPPFLAGS) $(CONS_CPPFLAGS) -I$(srcdir) -I$(basedir) $(CONSSRCS) >> Makefile
@if test -f Makefile ; then \
$(RMF) Makefile.bak; \
else \
$(MV) Makefile.bak Makefile; \
echo " ===== Something went wrong in make depend ====="; \
fi
# -----------------------------------------------------------------------
# DO NOT DELETE: nice dependency list follows
syntax highlighted by Code2HTML, v. 0.9.1