# New ports collection makefile for:	freeipmi
# Date created:				20/Oct/2004
# Whom:					Dmitry Frolov <frol@nov.net>
#
# $FreeBSD: ports/sysutils/freeipmi/Makefile,v 1.17 2007/12/15 12:02:52 pav Exp $
#
# Available KNOBs:
#
# WITH_DEBUG   - Build binaries suitable for debugging with gdb(1).
#

PORTNAME=	freeipmi
PORTVERSION=	0.5.1
CATEGORIES=	sysutils
MASTER_SITES=	ftp://ftp.zresearch.com/pub/freeipmi/${PORTVERSION}/ \
	ftp://ftp.riss-telecom.ru/pub/mirrors/ftp.zresearch.com/pub/freeipmi/${PORTVERSION}/

MAINTAINER=	frolov@riss-telecom.ru
COMMENT=	Library and tools to support IPMI-capable hardware

BUILD_DEPENDS+=	${LOCALBASE}/lib/libargp.a:${PORTSDIR}/devel/argp-standalone
LIB_DEPENDS+=	gcrypt:${PORTSDIR}/security/libgcrypt

USE_AUTOTOOLS=	libtool:15
USE_GMAKE=	yes
GNU_CONFIGURE=	yes
CONFIGURE_TARGET=	--build=${ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV+=	CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}" \
	PTHREAD_LIBS=-pthread
CONFIGURE_ARGS+=	--disable-init-scripts --disable-logrotate-config \
	--disable-logdir --localstatedir=/var \
	--with-ipmipower-config-file=${PREFIX}/etc/ipmipower.conf \
	--with-ipmi-monitoring-sdr-cache-dir=${CACHE_DIR}/ipmimonitoringsdrcache \
	--with-ipmi-monitoring-sensor-config-file=${PREFIX}/etc/ipmi_monitoring_sensors.conf \
	--with-ipmidetect-config-file=${PREFIX}/etc/ipmidetect.conf \
	--with-ipmidetectd-config-file=${PREFIX}/etc/ipmidetectd.conf
USE_LDCONFIG=	yes
NOT_FOR_ARCHS=	ia64 sparc64 alpha
PLIST_SUB+=	FREEIPMI_SHLIBVER=${FREEIPMI_SHLIBVER} \
	IPMICONSOLE_SHLIBVER=${IPMICONSOLE_SHLIBVER} \
	IPMIDETECT_SHLIBVER=${IPMIDETECT_SHLIBVER} \
	IPMIMONITORING_SHLIBVER=${IPMIMONITORING_SHLIBVER} \
	CACHE_DIR=${CACHE_DIR} LOG_DIR=${LOG_DIR} RUN_DIR=${RUN_DIR}
MAN3+=	libipmiconsole.3 libipmimonitoring.3 libipmidetect.3
MAN5+=	ipmipower.conf.5 bmc-config.conf.5 ipmiconsole.conf.5 \
	ipmidetect.conf.5 ipmidetectd.conf.5
MAN8+=	bmc-watchdog.8 ipmipower.8 ipmi-raw.8 ipmi-sel.8 \
	ipmi-sensors.8 ipmi-locate.8 bmc-info.8 ipmiping.8 \
	rmcpping.8 bmc-config.8 ipmiconsole.8 \
	ipmi-fru.8 pef-config.8 ipmimonitoring.8 ipmi-chassis.8 \
	ipmidetect.8 ipmidetectd.8
INFO+=		freeipmi-faq
PORTDOCS=	*

CACHE_DIR?=	/var/db/${PORTNAME}
LOG_DIR=	/var/log/${PORTNAME}
RUN_DIR=	/var/lib/${PORTNAME}
FREEIPMI_SHLIBVER=	5
IPMICONSOLE_SHLIBVER=	2
IPMIDETECT_SHLIBVER=	0
IPMIMONITORING_SHLIBVER=	1
CPPFLAGS+=	-I${LOCALBASE}/include
LDFLAGS+=	-L${LOCALBASE}/lib

.include <bsd.port.pre.mk>

.if ${OSVERSION} < 500112
BROKEN=	missing getpw*_r functions in this FreeBSD release
.endif

# Use i386_set_ioperm(2) instead of io(4) to gain access to I/O
# ports. Note: there is a bug in FreeBSD 5 before 5.5-RELEASE that
# causes SIGBUS to the process sometimes when i386_set_ioperm is used
# (PR 84842).
.if ${ARCH} == "i386" && defined(WITH_IOPERM)
CPPFLAGS+=	-DUSE_IOPERM
.endif

.if defined(WITH_DEBUG)
CONFIGURE_ARGS+=	--enable-debug --enable-trace
STRIP=	# empty
.endif

post-install:
	@${MKDIR} ${LOG_DIR}
	@${CHMOD} 0700 ${CACHE_DIR} ${LOG_DIR} ${RUN_DIR}

.include <bsd.port.post.mk>


syntax highlighted by Code2HTML, v. 0.9.1