#
# MakeFile for FVCool
#
INSTALL=install
INST_DIR=/usr/local/sbin
CC =gcc -fno-common
DEFS =-Wall
LIBS =
# the object files for fvcool
OBJ = fvcool.o
# the program
PRG = fvcool
# Linking Object Files
$(PRG): $(OBJ)
$(CC) -o $(PRG) $(OBJ) $(LIBS)
fvcool.o: fvcool.c
$(CC) -c fvcool.c $(DEFS)
clean:
@echo "FVCool Clean Process"
@echo "===================="
@echo
rm -f *~
rm -f *.~
rm -f *.o
rm -f fvcool
distclean: clean
rm -f Makefile config.cache config.log config.status
install:
@echo "FVCool Install Process"
@echo "======================"
@echo
$(INSTALL) -o root -g wheel -m 4555 -c -p $(PRG) $(INST_DIR)
@echo "Installation Complete !!!"
uninstall:
@echo "Uninstall FVCool... "
@rm -f $(INST_DIR)/fvcool
@echo "Ready"
help:
@echo "Make <Options>"
@echo "=============="
@echo " - compile FVCool"
@echo "clean - clean all object-files"
@echo "install - install FVCool"
@echo "uninstall - remove FVCool installation"
@echo "help - for this messsage"
syntax highlighted by Code2HTML, v. 0.9.1