# New ports collection makefile for:	gdmap
# Date created:		13 Oct 2005
# Whom:			Rodrigo Graeff <delphus@gmail.com>
#
# $FreeBSD: ports/sysutils/gdmap/Makefile,v 1.10 2007/10/24 23:36:38 marcus Exp $
#

PORTNAME=	gdmap
PORTVERSION=	0.7.5
PORTREVISION=	2
CATEGORIES=	sysutils gnome
MASTER_SITES=	${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR=	gdmap

MAINTAINER=	delphus@gmail.com
COMMENT=	Graphical disk map Utility

BUILD_DEPENDS=	${SITE_PERL}/${PERL_ARCH}/XML/Parser.pm:${PORTSDIR}/textproc/p5-XML-Parser

USE_X_PREFIX=	yes
USE_GNOME=	gnomeprefix gnomehack gtk20
USE_GMAKE=	yes
USE_PERL5=	yes
GNU_CONFIGURE=	yes

MAN1=	gdmap.1

post-patch:
	@${REINPLACE_CMD} -e 's,<sys/vfs.h>,<sys/statvfs.h>,' \
		${WRKSRC}/src/gui_main.c
	@${REINPLACE_CMD} -e 's|-D.*_DISABLE_DEPRECATED||g' \
		${WRKSRC}/configure

.include <bsd.port.mk>


syntax highlighted by Code2HTML, v. 0.9.1