# This is just a bootstrap Makefile.  The real one's are in the various subdir's.
build_it: src/Makefile
	if [ ! -f ./config.cache ] ; then ./configure ; fi
	cd src ; $(MAKE)

install: 
	cd src ; $(MAKE) install

clean: 
	rm -f a.out core *~ *.o *.a 
	cd conf ; rm -f a.out core *~ *.o *.a 
	cd doc ; rm -f a.out core *~ *.o *.a 
	cd scripts ; rm -f a.out core *~ *.o *.a 
	cd src ; $(MAKE) clean
	cd dd ; rm -f *~

distclean: clean
	rm -f config.status config.cache config.log 
	rm -Rf dd/tmp/

dd: clean
	if [ -d debian ] ; then mv -f debian debian.tmp ; fi
	ln -s dd debian
	dd/rules clean build binary
	rm -f debian
	if [ -d debian.tmp ] ; then mv -f debian.tmp debian ; fi


syntax highlighted by Code2HTML, v. 0.9.1