# New ports collection makefile for:	sensors-applet
# Date created:			03 May 2006
# Whom:				Jean-Yves Lefort <jylefort@FreeBSD.org>
#
# $FreeBSD: ports/sysutils/sensors-applet/Makefile,v 1.5 2007/10/24 23:36:41 marcus Exp $
#

PORTNAME=	sensors-applet
PORTVERSION=	1.6.1
PORTREVISION=	4
CATEGORIES=	sysutils
MASTER_SITES=	${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR=	${PORTNAME}

MAINTAINER=	jylefort@FreeBSD.org
COMMENT=	A GNOME applet displaying hardware sensor values

RUN_DEPENDS=	mbmon:${PORTSDIR}/sysutils/mbmon \
		smartctl:${PORTSDIR}/sysutils/smartmontools

USE_X_PREFIX=	yes
USE_GNOME=	gnomehack gnomeprefix intlhack gnomepanel
GNU_CONFIGURE=	yes
USE_GMAKE=	yes
DEFINES=	-DMBMON_EXECUTABLE=\\\"${LOCALBASE}/bin/mbmon\\\" \
		-DSMARTCTL_HELPER=\\\"${PREFIX}/libexec/smartctl-helper\\\"
CONFIGURE_ENV=	CPPFLAGS="-I${LOCALBASE}/include ${DEFINES}" \
		LDFLAGS="-L${LOCALBASE}/lib"

post-patch:
	@${CP} -f ${FILESDIR}/mbmon-sensors-interface.* \
		${FILESDIR}/smartctl-sensors-interface.* ${WRKSRC}/src

post-build:
	${CC} ${CFLAGS} -DSMARTCTL=\"${LOCALBASE}/sbin/smartctl\" \
		-o ${WRKSRC}/smartctl-helper ${FILESDIR}/smartctl-helper.c

post-install:
	${INSTALL_PROGRAM} ${WRKSRC}/smartctl-helper ${PREFIX}/libexec
	${CHMOD} u+s ${PREFIX}/libexec/smartctl-helper

.include <bsd.port.mk>


syntax highlighted by Code2HTML, v. 0.9.1