#
# Common rules and values used by all xosview Makefiles.
#
# The configure script should set up this file for most all cases.
# One can override compile / link options here if needed.
#
# $Id$
#
# version number for release
VERS = 1.8.3
TOP = @TOP_SRCDIR@
#-----------------------------------------------------------------
# C++ compiler
#-----------------------------------------------------------------
CXX = @CXX@
#-----------------------------------------------------------------
# Compiler flags
#-----------------------------------------------------------------
# Optimized CXXFLAGS
CXXFLAGS += $(CFLAGS) @EXTRA_CXXFLAGS@ -I@x_includes@ \
-DXOSVIEW_VERSION=\"$(VERS)\" -I$(TOP) -I$(TOP)/@host_dir@ @DEFS@
# DEBUG CXXFLAGS
#CXXFLAGS += $(CFLAGS) -Wall -ggdb -pipe -I@x_includes@ \
# -DXOSVIEW_VERSION=\"$(VERS)\" -I$(TOP) -I$(TOP)/@host_dir@ @DEFS@
# PROFILE CXXFLAGS
#CXXFLAGS += $(CFLAGS) -Wall -ggdb -pg -pipe -I@x_includes@ \
# -DXOSVIEW_VERSION=\"$(VERS)\" -I$(TOP) -I$(TOP)/@host_dir@ @DEFS@
#-----------------------------------------------------------------
# Link flags and libraries
#-----------------------------------------------------------------
# NORMAL LIBS
LFLAGS += -L$(TOP)/@host_dir@ -L@x_libraries@ @ELF_LINK_FLAGS@
LIBS += -lmeter @EXTRALIBS@ -lX11
# DEBUG LIBS
#LFLAGS += -L$(TOP)/@host_dir@ -L@x_libraries@ -static
#LIBS += -lmeter @EXTRALIBS@ -lX11
# PROFILE LIBS
#LFLAGS += -L$(TOP)/@host_dir@ -L@x_libraries@ -pg
#LIBS += -lmeter @EXTRALIBS@ -lX11 -lgmon
#-----------------------------------------------------------------
# Rules
#-----------------------------------------------------------------
## The GNU-style rule of %.o: %.cc is not as portable as .cc.o.
.cc.o:
$(CXX) $(CXXFLAGS) @CPP_DEP@ -c $< -o $@
@AUTODEPRULE@
syntax highlighted by Code2HTML, v. 0.9.1