# New ports collection makefile for: emerald
# Date created: Oct 29 2006
# Whom: Florent Thoumie <flz@FreeBSD.org>
#
# $FreeBSD: ports/x11-wm/emerald/Makefile,v 1.4 2007/10/29 19:36:13 flz Exp $
#
PORTNAME= emerald
PORTVERSION= 0.5.2
PORTREVISION= 1
CATEGORIES= x11-wm
MASTER_SITES= http://releases.compiz-fusion.org/${PORTVERSION}/
MAINTAINER= rnoland@2hip.net
COMMENT= Emerald Window Decorator
BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/compiz.pc:${PORTSDIR}/x11-wm/compiz
RUN_DEPENDS+= ${BUILD_DEPENDS}
INSTALLS_ICONS= yes
GNU_CONFIGURE= yes
USE_GL= gl
USE_BZIP2= yes
USE_GMAKE= yes
USE_GNOME= gnomehack gtk20 libwnck pango
USE_XORG= xrender
USE_GETTEXT= yes
USE_LDCONFIG= yes
USE_AUTOTOOLS= libtool:15
MAN1= emerald.1 \
emerald-theme-manager.1
CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib ${PTHREAD_LIBS}"
# XXX - might want to change that
post-patch:
@${REINPLACE_CMD} 's|icons/gnome|icons/hicolor|' ${WRKSRC}/misc/Makefile.in
.include <bsd.port.mk>
syntax highlighted by Code2HTML, v. 0.9.1